# Table of Contents

- Placing Components Using Unions and Radial Move .................................................. 1
- Copying Circuits Using Design Reuse ........................................................................ 6
- Checking for Trace Length Violations ....................................................................... 12
- Linking and Embedding Objects (OLE) ...................................................................... 14
- Creating Assembly Variants .................................................................................... 16
- Moving and Placing Components ............................................................................. 19
Placing Components Using Unions and Radial Move

In this lesson you will use additional component placement features to complete the placement of the tutorial design.

In this lesson:

- Placement with component unions
- Radial placement of components
- Automatic component nudging

Restriction

This tutorial requires the Cluster Placement, General Editing, and Radial Placement security options. On the Help menu, click Installed Options to determine whether you can proceed.

Preparation

If it is not already running, start PADS Layout and open the file named previewnet.pcb in the \PADS Projects\Samples folder.

Placement with component unions

Using the Cluster Placement feature, you can merge components together as a "super component," or union, as it is called in PADS Layout. Once the components exist as a union they move together instead of individually.

You can simplify component placement and reduce placement steps by creating component unions consisting of ICs and decoupling capacitors.

Dispersing Components

Distribute the components around the board outline using Disperse:

1. On the Tools menu, click Disperse Components.
2. Click Yes to confirm the dispersion.
Making the keepouts invisible

Change the visibility of keepouts:
1. On the Setup menu, click Display Colors.
2. In the Keepouts column, clear the check box, and click OK to accept the changes and close the Display Colors Setup dialog box.

Setting the net colors

Assign a color to the net +5V, to make the decoupling capacitors more visible during placement and orientation:
1. On the View menu, click Nets.
2. In the Net List, select +5V.
3. Click Add to add +5V to the View List.
4. In the View List, select +5V.
5. Select the dark gray color in the palette to display all component pins and vias connected to +5V in dark gray.

Setting the net visibility

Temporarily make the plane nets invisible to clear the design area and help in determining the best location for components:
1. In the View List, select Default and in the View Details area, clear the Traces Plus the Following Unroutes check box to make them invisible.
2. Click OK to apply the visibility settings and close the View Nets dialog box.

Positioning the union members

To create unions, group ICs and capacitors for each of the IC part types to enable the software to find and create similar unions automatically:
1. Press Home to fit the view to the board outline.
2. On the standard toolbar, click the Design button. The Design toolbar appears.
3. On the Design toolbar, click the Move button.
4. Search for and select component U1 using the search and select modeless command by typing ssu1 and pressing Enter.
5. Place U1 inside the PCB outline.
6. Type ssc1 to select capacitor C1 and press Enter.
7. Press Ctrl+R twice while moving to rotate C1 180 degrees.
8. Right-click and click **Flip Side** (Ctrl+F) to mount C1 on the Secondary Component Side.

9. Position C1 under U1 with the +5V pin almost directly under the +5V pin of U1, as shown below, and click to place C1.

![Diagram showing component placement](image)

**Placing other parts**

Create other component groups of ICs and capacitors.

- Repeat Steps 4 through 9 above with similar capacitor and IC placements for:
  - U7 and C2
  - U4 and C3
  - U5 and C4
  - U6 and C5

**Creating a union**

1. On the Design toolbar, click the **Select** button.

2. With nothing selected, right-click in the workspace and then click **Select Components**.

3. Select **U1** and Ctrl+click **C1** to add C1 to the selection.

   **Tip:** When creating the unions, it is important that the capacitor is the last selection before creating a union with an IC. If you do not select the IC first, the wrong origin is used when you place the component union.

4. With both components selected, right-click and click **Create Union**.

5. In the Union Name Definition dialog box, type `ic_cap1` as the union name and click **OK** to create the union.

6. Repeat steps 1 through 4 with the other capacitor and IC groups, using the union names:
   - U7 and C2 with union name `ic_cap2`
   - U4 and C3 with union name `ic_cap3`
   - U5 and C4 with union name `ic_cap4`
   - U6 and C5 with union name `ic_cap5`
Creating similar unions

To create similar unions, use the Create Like Unions command. This command looks for components with the same part types as the members of a base union and automatically merges them into a new union:

1. With nothing selected, right-click, and click **Select Unions/Components**.
2. Select the U1/C1 (ic_cap1) union.
3. Right-click and click **Create Like Unions**.
4. Click **Yes** to confirm the creation of like unions.
5. Click **Yes** to confirm the dispersion of new unions.
6. Repeat steps 2 through 5 for the U4/C3 (ic_cap3) union. All other unions are unique and do not have like part types.
7. Press Ctrl + Alt + E to view the extents of the design area. Examine the two new unions of components at the top left of the workspace.

Radial placement of components

The placement tools let you place components on a radial grid. Use the radial placement features to place the LEDs and resistors.

Setting the radial move grid

The radial placement tools let you specify all of the parameters for the radial grid:

1. Type the modeless command `gp` and press **Enter** to display the radial grid.
2. On the Design toolbar, click the **Radial Move** button.
3. In the Polar Grid Origin area, type **3000** in the X box and type **1100** in the Y box.
4. In the Inner Radius box, type **700**.
5. In the Delta Radius box, type **100**.
6. Leave all other settings at their default values.
7. Click **OK** to accept the changes and close the Radial Move Setup dialog box.
8. The polar grid origin is now located at the center of the arc radius.

Placing the LEDs and Resistors

Once the radial grid is established, move the components using the radial move command:

1. Type `ssd1` and press **Enter** to select and move D1.
2. Press **Ctrl + R** three times to rotate the component 270 degrees.
3. Place D1 on the inner radius of 700 at 45.000 degrees. See the Status Bar for the placement coordinates.

4. Type ssd2 and press Enter. Rotate D2 three times and place it at 315 degrees on the same radius.

5. Type ssr7 and press Enter. Rotate R7 once and place it at 15 degrees on the same radius.

6. Type ssr6 and press Enter. Rotate R6 three times and place it at 345 degrees on the same radius.

7. Turn off the radial grid by typing the modeless command gp and pressing Enter.

8. On the Design toolbar, click the Select button to exit the Radial Move command.

**Automatic component nudging**

This placement feature lets you automatically shove or nudge adjacent components when components are placed too close to each other or if they overlap:

1. On the Tools menu, click Options, and then click the Design page.
2. In the Nudge area, click Automatic to enable automatic nudging.
3. Click OK to apply the changes and close the Options dialog box.
4. With nothing selected, right-click and click Select Unions/Components.
5. Select a union, right-click and click Move. The component will attach to the pointer for moving.
6. Move it into a position where it slightly overlaps another union. Watch the software nudge the other union out of the way.
7. Do not save a copy of the design.

**You completed the placing components using unions and radial move tutorial.**
Copying Circuits Using Design Reuse

You can preserve a portion or subset of a PCB design for reuse within the design or in another design. The feature is referred to as physical design reuse. In a typical reuse procedure, you select a collection of design objects, define them as a reuse, and then save the reuse as a file for use in another design.

Another use of physical design reuse is replicating a portion of the current design and propagating the layout to other components and nets in the design. An example might be a multichannel, repeated circuit. Each channel circuit has identical component types, interconnects, and traces. You place and route a model of the channel circuit layout, select the model and use the PADS Layout Make Like Reuse command to locate and create all of the other channel layouts.

For this tutorial you will create a model circuit as a physical design reuse and then use the Make Like Reuse command to create the same circuit from duplicate components and nets in the design.

In this lesson:
- Defining a physical design reuse and saving it to a file
- Using Make Like Reuse command
- Breaking a physical design reuse
- Using Add Reuse command

Restriction

This tutorial requires the ECO, General Editing and Physical Design Reuse licensing options. On the Help menu, click Installed Options to determine whether you can proceed.

Preparation

If it is not already running, start PADS Layout and open the file named previewrules.pcb in the \PADS Projects\Samples folder.

Pre-placement Procedures

There are a few procedures you must complete before defining the reuse.

Setting a placement grid

Set a large grid for quick but accurate placement:
1. Set the design grid to 50 mils by typing g50 and pressing Enter.
2. Set the display grid to 50 mils by typing `gd50` and pressing Enter. The display grid may not be visible. If you want to see it, zoom in.

Dispersing the components
Disperse the components around the board outline for easy viewing.
1. On the Tools menu, click Disperse Components.
2. Click Yes to confirm the dispersion.
3. Press Ctrl+B to fit the view to the board outline.

Setting the net colors
Assign a color to the net +5V, to make the decoupling capacitors more visible during placement and orientation:
1. On the View menu, click Nets.
2. In the Net List, select +5V.
3. Click Add to add +5V to the View List.
4. In the View List, select +5V.
5. Select the dark gray color in the palette to display all component pins and vias connected to +5V in dark gray.
6. Click OK to apply the changes and close the dialog box.

Setting object visibility
Make the selection process more obvious by making connections visible.
1. On the Setup menu, click Display Colors.
2. In the Selected Color area, select light green and in the Other area, click Connection.
3. Click OK to apply the changes and close the dialog box.

Defining a physical design reuse
To define a physical design reuse, select all of the objects to include in the physical design reuse in the Layout Editor. Once you make the selection, use the Make Reuse command to convert the collection of objects into a physical design reuse object:

Arranging the parts
Arrange the parts in the circuit to use as your physical design reuse model:
1. On the Design toolbar, click the Move button.
2. Type the modelless command `ssu1` and press Enter to select U1.
3. Using the Status Bar as a guide, place U1 at X1400,Y800.
4. Type ssu3 and press Enter to select U3, and then place U3 at X2050,Y800.
5. Type ssr1 and press Enter to select R1, and then place R1 at X2050,Y550.
6. Place the decoupling capacitors C1 and C6 for U1 and U3:

<table>
<thead>
<tr>
<th>Component</th>
<th>Move to</th>
</tr>
</thead>
<tbody>
<tr>
<td>C1</td>
<td>1150 1000 Flipped and rotated 180 degrees</td>
</tr>
<tr>
<td>C6</td>
<td>1950 900 Flipped and rotated 180 degrees</td>
</tr>
</tbody>
</table>

Creating a physical design reuse

Once you place the model of the circuit to reuse, use the Make Reuse command to define it as a reuse:

1. On the Design toolbar, click the Select button.
2. With nothing selected, right-click and click Filter.
3. Click the Nothing button to clear all selections.
4. In the Design Items list, select the Parts and Nets check boxes.
5. Close the selection filter dialog box.
6. Using area selection, select all of the components you placed.
7. Right-click and click Make Reuse.
8. In the Make Reuse dialog box, in the Reuse Type box, type Preview and accept the Reuse Name of PREVIEW_1.
9. Select the Save to File check box.
10. Click Deselection Report.

Result: A report file appears in the default text editor. Items in the selection that are not valid for a physical design reuse, such as partially selected pin pairs or trace objects, are removed automatically from the selection and appear in this report.

12. In the Make Reuse dialog box, click OK.
13. In the Reuse Save As dialog box, accept the reuse name of Preview.reu and click Save to save the physical design reuse to a file. The first instance of the physical design reuse PREVIEW_1 is the currently selected item.

Creating duplicate physical design reuses

The Make Like Reuse command uses an existing physical design reuse as a pattern and parses the design for a combination of component part types and interconnects that match. If a match is found, Make Like Reuse arranges the parts and interconnects them to match the reuse.
1. Select the physical design reuse and on the Design toolbar, click the Make Like Reuse button.

2. After clicking the Make Like Reuse button, a collection of components combine into a second instance of the Preview reuse and attaches to the pointer.

3. Place the PREVIEW_2 reuse physical design at X1150, Y1700.

**Breaking a physical design reuse**

Once a physical design reuse is defined, you can modify most elements belonging to the reuse. These restrictions maintain the integrity of the reuse. Before you can edit elements belonging to a reuse you must break or dissolve the reuse.

1. If a reuse is not currently selected, select a component element of the physical design reuse, and then right-click and click **Select Reuse**.

2. Right-click and click **Break Reuse**.

3. Click **OK** to confirm the breaking of the reuse.

4. In preparation for the next exercise, break the other physical design reuse by repeating steps 1 through 3.

5. On the Tools menu, click **Disperse Components** to disperse the components and click **Yes** to confirm the dispersion.

6. Press **Home** to fit the view to the board outline.

**Adding a physical design reuse**

Adding a physical design reuse to a design is an ECO operation. The Add Reuse command adds a physical design reuse to your design.

Add a reuse from a saved file using the Add Reuse command:

1. On the Standard toolbar, click the ECO button.

2. In the ECO Preferences dialog box, clear the **Write ECO File** check box and click **OK**.

3. On the ECO toolbar, click the **Add Reuse** button.

4. In the Add Reuse File dialog box, select the **Preview.reu** file you saved in a previous exercise.

5. Click **Open**. After a moment the Reuse Properties dialog box appears.

**Tip:** To make a copy of a reuse that exists in the design, select the reuse and then click Add Reuse.
Assigning reuse properties

Use the Reuse Properties dialog box to manage the reference designators and net conflicts that occur when merging the design objects contained in a physical design reuse into a design. Use the Reuse Properties dialog box to assign reference designators and a merge/no merge status for each net in the physical design reuse.

1. In the Designator Preferences area, select **Start at**, and then type **100** as the starting number for the parts added to the design.
2. Click **Net Properties**.
3. In the Add/Merge in Design(Public) list, select the three nets with a $$$ prefix.
4. Click <><< to move the nets to the Rename in Design list. This prevents these reuse nets from merging with nets of the same name in the design when the reuse is added. The net objects in the physical design reuse are renamed with a suffix of A when added to the design.
5. Click **OK** to close the Net Properties dialog box.
6. Click **OK** to close the Reuse Properties dialog box.
7. When asked if you want to view a report file, click **Yes**. Take a moment to review the contents of the report file, and then close the report file when you are ready to continue.

**Result:** The physical design reuse is added to the design and is attached to the pointer.
8. Click to place the physical design reuse.

Making a copy of a physical design reuse

Use the Add Reuse command to make a copy of a physical design reuse in your design.

1. Select a component element in the reuse you added in the previous exercise.
2. Right-click and click **Select Reuse**.
3. On the ECO toolbar, click the **Add Reuse** button.
4. In the Reuse Properties dialog box, note how the Start at Designator Preferences is automatically incremented to 200.
5. Click **Net Properties**. In the Net Properties dialog box, note how the net properties from the physical design reuse are propagated to the copy of the physical design reuse. Note how the Net Appended Suffix for the net rename is also updated.
6. Click **OK** to close the Net Properties dialog box.
7. Click **OK** to close the Reuse Properties dialog box.
8. When asked if you want to view a report file, click **No**.
**Result:** The physical design reuse is added to the design, and is attached to the pointer.

9. Click to place the physical design reuse.
10. Do not save a copy of the design.

You completed the copying circuits using design reuse tutorial.
Checking for Trace Length Violations

Setting up for Electrodynamic Checking (EDC) is more complex than for simple space checking, because EDC can perform tandem track checking, or search for parallelism violations across layers. You must describe the layer thickness, copper thickness, and dielectric constant, all based on manufacturing material and tolerances specified for the board. Entering this information allows you to work backwards to find out what tolerances are necessary to properly configure your design.

In this lesson:

- Assigning a high-speed design rule
- Performing an electrodynamic check

Restriction

This tutorial requires the Advanced Rules, General Editing and Verify Design security options. On the Help menu, click Installed Options to determine whether you can proceed.

Preparation

If it is not already running, start PADS Layout and open the file named previewdim.pcb in the \PADS Projects\Samples folder.

Assigning a high-speed design rule

To demonstrate the capabilities of EDC, add a net length rule to the net 24MHz.

2. In the Rules dialog box, click the Net button.
3. In the Net Rules dialog box, select 24MHz, and click the HiSpeed button.
4. In the HiSpeed Rules dialog box, change the maximum allowable net Length to 1.200 by typing 1.200 in the Maximum box.
5. Click OK to close the High Speed Rules dialog box and apply the rule.
6. Click Close to close the Net Rules dialog box, and click Close again to close the Rules dialog box.
Performing an electrodynamic check

Setup:

1. **Tools** menu > **Verify Design**.
2. In the Check area, click **High Speed** and then click **Setup**.
   
   In the Electrodynamic Check dialog box, you add nets or net classes for the specific checks you want to use.
3. Click **Add Nets**. The Add Net Tasks dialog box appears.
4. In the Nets list, select **24MHz** and click **OK**.
5. Enable all checks for net 24MHz so that EDC checks for Capacitance, Impedance, Parallelism, Tandem, Length, Delay, Stubs, and Loops.

Specify the checks to perform:

1. Click **Parameters**. The EDC Parameters dialog box appears.
2. In the Parallelism area, in the Check Against list, select **Nets/Pin Pairs**.
3. In the Report Detail list, select **Aggressors/Victims**.
4. In the Other Checks area, in the Check Against list, select **Nets/Pin Pairs**.
5. In the Report Detail list, select **Nets**.
6. Select the **Include Copper** check box.
7. In the Daisy Chain area, in the Report Detail area, select **Stubs**.
8. Select the **Report Segment Coordinates** check box.
9. Select the **Report Violations Only** check box.
10. Click **OK** to close the EDC Parameters dialog box.
11. Click **OK** to close the Electrodynamic Check dialog box.

Start the EDC check:

1. Click **Start** on the Verify Design dialog box.

   **Result:** After a moment the Verify Design process completes and displays a Length out of range message for net 24MHz.

2. Use the trace editing commands to modify the net length of net 24MHz and run the test again. Routing the trace from U7.1 to Y1.3 on the top layer in the most direct route will reduce the trace length to less than 1.2 inches. You might need to move a via or set a finer design grid.

3. When you complete the correction, click **Close** to exit the Verify Design dialog box.
4. Do not save a copy of the design.

**You completed the checking for trace length violations tutorial.**
Linking and Embedding Objects (OLE)

Object embedding capabilities allow design engineers to embed a foreign data object into a design file. This allows the design file to act as a placeholder for engineering data. Furthermore, the embedding capabilities allow the engineer to edit the embedded objects from within the design using the object's native application.

The object linking capabilities allow you to link embedded objects to their source. Updates to the source object are brought into the design automatically each time you open the design.

The Automation features enable engineers to develop custom applications using object-oriented programming (OOP) techniques to develop custom plug-in applications using tools such as Microsoft Visual Basic®, Microsoft Excel®, and Microsoft Visual C++®.

In this lesson:
- Embedding an object
- Resizing and repositioning an embedded object
- Changing the background color of an embedded object
- Editing an embedded object

Preparation

If it is not already running, start PADS Layout and open the file named `previewdim.pcb` in the `\PADS Projects\Samples` folder.

Embedding an object

1. **Edit** menu > **Insert New Object**.
2. Select **Create from File** so you can browse for a document.
3. Click **Browse**.
4. In the Browse dialog box, navigate to the `\PADS Projects\Samples` folder and select `PCB Notes.doc`.
5. Click **Open**. The document appears in the work area and is the currently selected object.
Resizing and repositioning an object

When the document appears, it displays at full size. You can resize it and reposition it so it does not obstruct the view of the PCB.

To resize and reposition the object:

1. Alter the document's size by placing the pointer over one of the move handles (black squares) on the corner of the document until a diagonal arrow appears.
2. Drag the pointer toward the center of the document. Release the left mouse button when the outline is about 1/3 its original size.
3. Drag the document to an unused portion of the workspace below the board.

Changing the background color of an embedded object

- With the embedded document still selected, right-click. A check mark should appear beside White Background. Click White Background to clear the check mark. The document background is now the same color as the workspace.

Editing an embedded object

You can edit the embedded document by double-clicking it. This starts the application used to create the document.

1. Resize the view so the embedded object fills the view.
2. Double-click the embedded object.

   Result: A new window opens and the PADS Layout menus are replaced with those of the application used to create PCBNotes.doc.

3. Double-click the word millimeters in Note 1 and type inches, replacing the original text.
4. Click anywhere in the PADS Layout workspace to save the document and return to PADS Layout.
5. Do not save a copy of the design.

You completed the linking and embedding objects tutorial.
Creating Assembly Variants

You can quickly and easily document design variations made from a single source PCB design. You can define variants through a simple, table-driven user interface. As variations are added, designers can preview them with a graphical preview.

In this lesson:
- Defining an assembly variant

Restriction
This tutorial requires the Assembly Variants and CAM licensing options. On the Help menu, click Installed Options to determine whether you can proceed.

Preparation
If it is not already running, start PADS Layout and open the file named previewole.pcb in the \PADS Projects\Samples folder.

Defining an assembly variant

You define assembly variants using the Assembly Variants dialog box. You must first define a new variant name and then assign the component status of installed, not installed, or substituted for each member of the variant.

Creating a variant
2. In the New variant’s name box, type Build01.
3. In the Variant area, click Create. You can now define a Build01 assembly.

Assigning component status
Remove components from the new assembly variant by changing the status of some components.
1. In the Name column, Shift+click U1 and U2.
2. In the Status area at the top of the dialog box, select Not Installed. The Status for U1 and U2 changes to Not Installed.
Creating Assembly Variants

Previewing the build assignment

Examine an assembly drawing of the new assembly variant to see the changes.

1. In the Variant area, click Preview.
   
   **Result:** A preview for Build01 appears in a new window. Notice the disappearance of U1 and U2 (the two large SO28s).

2. In the Preview window, click Variants. The Preview/Option dialog box appears.

3. On the line for the Build01 variant, double-click the **Not Installed** cell. A list of viewing options appears.

4. Select Color to open the Colors dialog box.

5. Select the red color and click OK.
   
   **Result:** All of the Not Installed components in Build01 are now red.

6. Click OK in the Preview/Option dialog box.

   In the preview for Build01 window you can now see a view of the board that shows which components are installed for the assembly variant Build01.

   **Tip:** You can zoom in by clicking and zoom out by right-clicking.

7. When you finish viewing the preview for Build01, click Close.

   Although no change is made to the design itself, Reports and CAM outputs can be created based on the assembly variant instead of the base variant.

Creating a variant parts list

Use the Report button in the Assembly Variants dialog box to generate reports including parts lists based on the variant and not the original design:

1. In the Variant area, click Reports. The Reports dialog box appears.

2. In the Select Report Files for Output list, select Parts List 1

3. Select the **Use Assembly Variant** check box.

4. In the Name list, select Build01.

5. Click OK to produce the report.
   
   **Result:** The parts list appears in the default text editor. Examine the list and note the <Not installed> text for U1 and U2.


7. In the Assembly Variants dialog box, click OK to save the assembly variant definition and close the dialog box.
Creating an assembly variant CAM document

When outputting an Assembly CAM document, click the Assembly button in the Customize Document section of the Add/Edit Document dialog box to use the variant for its generation:

1. On the File menu, click CAM.
2. In the CAM Documents dialog box, click Add.
3. In the Document Type list, select Assembly.
4. When the Layer Association dialog box appears, click OK to accept the default Primary Component Side setting.
5. In the Customize Document area, click the Assembly button.
6. In the Select Assembly Variant dialog box, select the Use Assembly Variant check box.
7. In the Name list, select Build01, and then click OK.

   The Assembly document produced will be based on the chosen variant.
8. In the Add Document dialog box, click Preview Selections.
9. In the CAM Preview window that opens, click Board. Note the absence of the U1 and U2 SO28 devices that were located on the Primary Component Side.
10. Close all open CAM windows.
11. Do not save a copy of the design.

   You completed the creating assembly variants tutorial.
Moving and Placing Components

Typically, parts are placed by selecting them and moving them into position within the board outline. However, PADS Layout contains various features that minimize the number of steps required to locate and place parts on the printed circuit board, thereby reducing actual design time.

In this lesson:
- Setting the move origin
- Moving components using Move
- Rotating components using Rotate 90
- Rotating components using Spin
- Flipping components using Flip Side
- Combining Move with Rotate 90, Spin, and Flip Side
- Applying Move, Rotate 90, and Flip Side with multiple components selected
- Changing the placement status of a part using properties

Restriction
This tutorial requires the General Editing licensing option. To determine whether you can proceed:
- On the Help menu, click Installed Options.

Preparation
If it is not already running, start PADS Layout and open the file named previewrules.pcb in the \PADS Projects\Samples folder.

Setting the move origin

You can choose between three origins for moving objects.

Origin types:

<table>
<thead>
<tr>
<th>Origin</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>By Pointer Location</td>
<td>The pointer location at the time of initiating the component move.</td>
</tr>
<tr>
<td>By Origin</td>
<td>The actual component origin as defined in decal creation.</td>
</tr>
<tr>
<td>By MidPoint</td>
<td>The geometric center of the component.</td>
</tr>
</tbody>
</table>
For the purpose of the exercises below, the move-by mode should be set to Move By Origin:

1. On the **Tools** menu, click **Options** and then click the **Design** page.
2. In the Move Preference area, click **Move By Origin**.
3. Click **OK**.

**Moving components using Move**

Move components using the Move command. Although there are several ways to start the move command we will use the Move command from the shortcut menu:

1. Right-click and click **Select Components**.
2. Place the pointer over the parts at the design origin and click a component. **Tip**: Select a surface mount component for best results with all of the exercises to follow.
3. Right-click and click **Move**.
   **Alternative**: Press Ctrl+E
4. With the part attached to the pointer, move it inside the board outline, and click to complete the move.
   **Tip**: Use the Move button on the toolbar to lock the pointer in a Move mode. Everything selected will be moved immediately without having to activate the move command each time.

**Rotating components using Rotate 90**

You can rotate a component counterclockwise in 90-degree increments around its origin using Rotate 90.

- With the component in the above exercise selected, right-click and click **Rotate 90**.
  **Alternative**: Press Ctrl+R

**Rotating components using Spin**

You can rotate components clockwise or counterclockwise at an angular precision of .001 degrees using Spin.

1. With the component in the above exercise selected, right-click and click **Spin**.
   **Alternative**: Press Ctrl+I
2. Move the pointer around the component. The component follows the motion of the pointer, rotating around the component origin.
3. Rotate the component until the Status Bar (grid size area) displays an angle of \textbf{270.000} and click to complete the spin.

\textbf{Tip:} To spin the component in coarse radial increments, spin the component with the pointer closer to the component origin. To spin the component in fine radial increments, spin the component with the pointer further from the component origin.

\section*{Flipping components using Flip Side}

You can move a component to the opposite mounting side of the board using Flip Side.

1. With the component in the above exercise selected, right-click and click \textbf{Flip Side}.

\textbf{Alternative:} Press Ctrl+F

2. Click in an open area of the design to deselect it.

\textbf{Result:} The components mounted side flips from the Primary Component Side to the Secondary Component Side. Note how the component outline and pad colors change to the outline and pad colors for the Secondary Component Side.

\section*{Combining Move with Rotate 90, Spin, and Flip Side}

You can Rotate 90, Spin, and Flip Side while moving a component. Initiate the Move command (with the component selected, right-click and click Move), then click another command from the shortcut menu while the part is attached to the pointer.

\section*{Applying Move, Rotate 90, and Flip Side with multiple components selected}

You can apply the same commands used to move a single component to a multiple component selection.

Move a few more components from the origin onto the board and experiment with the Move, Rotate 90, Flip Side, and Spin commands with more than one component selected.

\section*{Changing the placement status for a part using properties}

You can view and modify various details about a part in the Component Properties dialog box.

1. Select a component, right-click, and click \textbf{Properties}. 

Moving and Placing Components
2. Experiment with the use of the Properties dialog box changing the layout data of the component.
3. Do not save a copy of the design.

You completed the moving and positioning components tutorial.